mcxx: remove build dependency with icc

This commit is contained in:
Rodrigo Arias Mallo 2020-07-10 16:42:33 +02:00
parent 261d304961
commit 7c68efe743
3 changed files with 27 additions and 4 deletions

View File

@ -10,7 +10,6 @@
, flex
, bison
, gcc
, icc
}:
stdenv.mkDerivation rec {
@ -38,12 +37,18 @@ stdenv.mkDerivation rec {
bison
flex
gcc
icc
];
patches = [ ./intel.patch ];
preConfigure = ''
export ICC=icc
export ICPC=icpc
export IFORT=ifort
'';
configureFlags = [
"--enable-ompss-2"
"--with-nanos6=${nanos6}"
];
}

19
bsc/mcxx/intel.patch Normal file
View File

@ -0,0 +1,19 @@
--- a/configure.ac 2020-07-10 16:15:11.431606455 +0200
+++ b/configure.ac 2020-07-10 16:15:24.291586572 +0200
@@ -367,16 +367,6 @@
[ enable_intel_compilers="yes"])
AC_MSG_RESULT([$enable_intel_compilers])
-
-IFORT=
-ICC=
-ICPC=
-if test x"$enable_intel_compilers" = x"yes";
-then
- AC_CHECK_PROG([IFORT], [ifort], [ifort])
- AC_CHECK_PROG([ICC], [icc], [icc])
- AC_CHECK_PROG([ICPC], [icpc], [icpc])
-fi
dnl --------------- END Intel Compilers ---------------------
mic_compilation="no"

View File

@ -72,7 +72,6 @@ let
};
mcxx = callPackage ./bsc/mcxx/default.nix {
icc = icc;
stdenv = pkgs.gcc9Stdenv;
nanos6 = nanos6-git;
};